Updated to Layers Pro, now Customizer won’t load

Asked on June 25, 2016 in Troubleshooting.

Hi,
I’ve been using Layers for a while in a site with loads of pages (53). Everything working ok until I decided to update to Layers Pro. Then I got the blank page customizer.

Fortunately I can deactivate the Layers Pro plugin to get back my customizer but I’d love to be able to customize the rest of the Pro features.

I’ve tried your tips for performance here to no avail. I hoped the new version would help but it hasn’t. I’d like to avoid turning most pages static if there’s another option.

Layers Pro version 1.6.4.
Layers version 1.5.4.

Thanks for your help!

Dani Layers User
Reply
1 Answer(s)
Answered on June 28, 2016.

In the future please contact us via Layers Messenger for assistance with Pro or any technical issue you need a quick response from the Layers Team.

53 pages is an enormous amount of work for your database and unless you have premium hosting, is going to kill your customizer because there is not enough PHP memory allocated to handle that amount of widget data.

If you have a child theme active, deactivate it and activate Layers. If thissolves it, check for a theme update before reactivating.  

The first thing I recommend trying is a complete reinstall of Layers 1.5.4 if you previously used the auto updater. This means temporaroly activating a different theme, then deleting layers, reinstalling it with a fresh download, then reactivating it.  If you updated Pro using FTP overwrites, also completely deactivate/delete and reinstall using the WordPress interface instead. Once activated, turn off any other Layers plugins you’re running, or plugins that add widgets you are using. If you are using JetPack, turn off widget visibility, extra sidebar widgets and subscriptions.
Now go to Appearance > Widgets and remove all inactive widgets.
Finally, return to the Appearance > Customize page and see if you get your Edit Layout. If so, you have a plugin conflict and will need to troubleshoot by selective reactivation. If you don’t, you will need to first work with your host to determine if there are memory or max variable limits being reached. The max variables can be enabled and increased in your php.ini. The PHP memory is set by your host and can be increased if they allow it. If these pages include widgets created by 3rd parties as part of other Layers extensions, make sure the extension is updated for full 1.5 compatibility before reactivating it. Note that Layers Pro is coded to be inherently compatible with Layers and will always take precedence over an extension or child theme – 3rd party products coded properly should always work with Layers Pro.

I am having the same problem.  (WP 4.9.1, Layers 2.0.7, Layers Prp 2.0.1, PHP 7.1).  If I have Layers Pro activated when trying to access customizer I get a blank screen in Google Chrome or a “Content encoding error” message in Firefox.  If I downgrade to Layers 1.6.5, everything works fine.  This is with all plugins deactivated except Layers Pro.

on December 8, 2017.

Were you ever able to resolve this?  I’m having the same problem on two unrelated websites.  These are small 5 page sites.

on January 4, 2018.

I FOUND MY PROBLEM!  I hope this helps someone else.  The problem was with Godaddy!  They were running a beta program which installed a script on my site.     I called them to try disabling this script to see if that was causing my customizer to not load with Layers Pro.  Once their script was disabled, Layers Pro worked fine!!!!!!

Here’s the script put on my site by Godaddy. If you’re having this issue, take a look at your Godaddy hosting.

<script>’undefined’=== typeof _trfq || (window._trfq = []);’undefined’=== typeof _trfd && (window._trfd=[]),_trfd.push({‘tccl.baseHost’:’secureserver.net’}),_trfd.push({‘ap’:’cpsh’},{‘server’:’a2plcpnl0854′}) // Monitoring performance to make your website faster. If you want to opt-out, please contact web hosting support.</script><script src=’https://img1.wsimg.com/tcc/tcc_l.combined.1.0.6.min.js’></script>

on February 7, 2018.
Reply