Layout gone on upload

Asked on November 30, 2015 in Troubleshooting.

First of all thank you for developing Layerswp, i really like this theme a lot. It help me build websites faster and beautiful.

I got a problem i’ve never encountered before, so after i finished customizing all layerswp page on localhost, i uploaded the wordpress folder and the database, changed the wp_options folder like always, but when i access the page it’s all gone, only the header and footer shows up, all CSS and widget from my page is gone.

 

What did i do wrong? How can i fix it?

 

Thanks.

Christian Dimas Layers User
Reply
2 Answer(s)
Answered on November 30, 2015.

Hi there,

Your Layers widget data is stored in wp_options under the active theme name, so if you originally set everything up under Layers, then moved it into production and now have a child theme active, none of the page content will be there until you import it. Same goes if you wipe the wp_options table, it takes that data with it. We recommend the following process for exporting your content when moving WordPress:
https://docs.layerswp.com/doc/backup-your-pages/

If you are encountering issues where you are doing a full db restore, make sure the wp-content folder has also been transferred over, and that the site url and wordpress url have been updated, THEN resave permalinks on the same setting you used for setup.

The backup is used when i use another theme right?

But in my case, i built the site using layerswp theme and localhost, and i just want to move it to my domain, also using layerswp. Just checked, all the CSS inside customizer is gone too, the CSS in the wordpress panel is imported.

on December 1, 2015.
Reply
Answered on December 14, 2015.

Problem fixed!

 

What i do is, uploading all the files over again, and make the wp_options table again, i think the previous one is corrupted because the connection is bad when uploading.

Reply