What Page Builder Plugins are Compatible With Layers?

FAQ  Troubleshooting  Last Updated: Time to Read: 1 minute

Layers Extensions are the only plugins designed and tested for Layers sites.

Layers is designed to free your site from the overhead and page load that most page builder plugins introduce into WordPress. Plugins like Visual Composer, Beaver Builder and Page Builder should only be used with the Layers template when absolutely necessary to avoid potential performance issues in the customizer . 3rd Party widget data may not be retained the same way as Layers (because Layers is not designed for these plugins), and builder sections may add foreign HTML and scripting to your Layers pages that can lead to unpredictable results we will not be able to support.

Visual Composer should work with Layers static page templates, and posts. For help and support, visit their support page.

We have found Shortcodes Ultimate and other plugins that add elements via Shortcodes have the best outcome, as the shortcodes can be placed in the Content Widget. If you need to use a specific builder within Layers, please contact the plugin author and ask them to test on Layers to help build in compatibility with our free framework. Note that these builder plugins may work fine when used in your posts or with the Blank page template.

Plugins that have a standalone purpose and widget (such as a Slider plugin) tend to work fine in Layers pages. It is important to understand that 3rd Party widgets are not necessarily designed to the same standards as Layers, so may need styling adjustments. When considering premium plugins, we recommend contacting the author to ask them to test on Layers (as it is free) to help determine compatibility, or check to see if there is a Layers equivalent – they are often less expensive.

For more on plugin compatibility and Layers, see our Plugin Compatibility doc.