Close

Layers Help & Support

Layers 2.0.10 Update

Layers 2.0.10 Update

Removing the Envato Marketplace listings.

  • Fixed Image Ratio button in the Post widget
  • Removed redundant Envato Market listings

UPDATE LAYERS View on GitHub

Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use __construct()

Troubleshooting  Last Updated: Time to Read: Less than a minute

If you are not a developer but are seeing this error on your install, ensure all of your plugins and child themes are up to date and that you are running the latest version of Layers. Extensions or themes that continue to produce this error require the author to update the code using the following instructions.

If you run with debug on and have installed WordPress 4.3 RC or the full release, you will see this message if a plugin is active that uses a PHP 4 constructor. This may also pertain to constructors in themes that are including standard (non-Layers) widgets.

Here is how the old constructor looks in a Layers Widget:

Update your widgets with the following structure:

See Layers Plugin Guide: Layers Builder Widgets for full updated guidelines or catch up with the WordPress 4.3 Dev Notes.

Did you know?

Our friends at Jetpack are doing some incredible work to improve the WordPress experience. Check out Jetpack and improve your site's security, speed and reliability.

Jetpack